Jump to content


Member Since 13 Jun 2019
Offline Last Active Nov 15 2019 01:53

Topics I've Started

chasing inspiration bug

06 November 2019 - 04:18

there is a bug in the quest chasing inspiation.  1. i talked with mage kew. 2. I equipped the red soil essence I kill more than  needed wisps and the quest still says: "used red soil on 0 of three wisps"  whatever I do the count os wisps remains zero. i tried restarting  eldevin an repeting everything  aand my kills of wisps using the red sil remains zaro. I tried  swiching servers and repeat the quest and  still the quest still states o of 3 red soil used. Please help!

i was playing just a sec ago and game crashed from nothing and doesn't load agin a...

26 October 2019 - 00:21

i was playing just a sec ago and the game crashed out of nothing  and doesn't  load again any more after several efforts

quest missing patrol part 4 appears as unfulfilled despite being completed

10 July 2019 - 16:01

hi there,  the quest  "missing patrol" part 4 "find the sword hilt"  appears as unfulfilled despite being completed and having the quest item  - the sword hilt - in my inventory.


Arial | Calibri | Lucida Console | Verdana
Font Size:
9px | 10px | 11px | 12px | 10pt | 12pt